Tue Jul 05 2022

WebKitGTK and WPE WebKit Security Advisory WSA-2022-0006

Several vulnerabilities were discovered in WebKitGTK and WPE WebKit.

  • CVE-2022-22662

    • Versions affected: WebKitGTK and WPE WebKit before 2.36.0.
    • Credit to Prakash (@1lastBr3ath) of Threat Nix.
    • Impact: Processing maliciously crafted web content may disclose sensitive user information. Description: A cookie management issue was addressed with improved state management.
  • CVE-2022-22677

    • Versions affected: WebKitGTK and WPE WebKit before 2.36.4.
    • Credit to an anonymous researcher.
    • Impact: The video in a webRTC call may be interrupted if the audio capture gets interrupted. Description: A logic issue in the handling of concurrent media was addressed with improved state handling.
  • CVE-2022-26710

    • Versions affected: WebKitGTK and WPE WebKit before 2.36.4.
    • Credit to Chijin Zhou of ShuiMuYuLin Ltd and Tsinghua wingtecher lab.
    • Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A use after free issue was addressed with improved memory management.

We recommend updating to the latest stable versions of WebKitGTK and WPE WebKit. It is the best way to ensure that you are running safe versions of WebKit. Please check our websites for information about the latest stable releases.

Further information about WebKitGTK and WPE WebKit security advisories can be found at: https://webkitgtk.org/security.html or https://wpewebkit.org/security/.

Home