Fri Apr 08 2022

WebKitGTK and WPE WebKit Security Advisory WSA-2022-0004

Several vulnerabilities were discovered in WebKitGTK and WPE WebKit.

  • CVE-2022-22624

    • Versions affected: WebKitGTK before 2.36.0 and WPE WebKit before 2.34.7.
    • Credit to Kirin (@Pwnrin) of Tencent Security Xuanwu Lab.
    • Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A use after free issue was addressed with improved memory management.
  • CVE-2022-22628

    • Versions affected: WebKitGTK before 2.36.0 and WPE WebKit before 2.34.7.
    • Credit to Kirin (@Pwnrin) of Tencent Security Xuanwu Lab.
    • Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A use after free issue was addressed with improved memory management.
  • CVE-2022-22629

    • Versions affected: WebKitGTK before 2.36.0 and WPE WebKit before 2.34.7.
    • Credit to Jeonghoon Shin at Theori working with Trend Micro Zero Day Initiative.
    • Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A buffer overflow issue was addressed with improved memory handling.
  • CVE-2022-22637

    • Versions affected: WebKitGTK before 2.34.4 and WPE WebKit before 2.34.4.
    • Credit to Tom McKee of Google.
    • Impact: A malicious website may cause unexpected cross-origin behavior. Description: A logic issue was addressed with improved state management.

We recommend updating to the latest stable versions of WebKitGTK and WPE WebKit. It is the best way to ensure that you are running safe versions of WebKit. Please check our websites for information about the latest stable releases.

Further information about WebKitGTK and WPE WebKit security advisories can be found at: https://webkitgtk.org/security.html or https://wpewebkit.org/security/.

Home