WPE WebKit

A WebKit port optimized for embedded devices

12 March 2020

WebKitGTK and WPE WebKit Security Advisory WSA-2020-0003

  • Date Reported: March 12, 2020

  • Advisory ID: WSA-2020-0003

  • CVE identifiers: CVE-2020-10018.

Several vulnerabilities were discovered in WebKitGTK and WPE WebKit.

  • CVE-2020-10018
    • Versions affected: WebKitGTK before 2.28.0 and WPE WebKit before 2.28.0.
    • Credit to Sudhakar Verma, Ashfaq Ansari & Siddhant Badhe - Project Srishti of CloudFuzz.
    • Impact: Processing maliciously crafted web content may lead to arbitrary code execution. Description: A memory corruption issue (use-after-free) was addressed with improved memory handling.

We recommend updating to the latest stable versions of WebKitGTK and WPE WebKit. It is the best way to ensure that you are running safe versions of WebKit. Please check our websites for information about the latest stable releases.

Further information about WebKitGTK and WPE WebKit security advisories can be found at: https://webkitgtk.org/security.html or https://wpewebkit.org/security/.

Home

Contact